openssh-server ubuntu 安装不上 安装失败

 

尝试 ,失败

sudo apt-get install ssh-contact-service
正在读取软件包列表… 完成
正在分析软件包的依赖关系树… 完成
正在读取状态信息… 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
ssh-contact-service : 依赖: openssh-server
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

尝试 ,失败

apt-get install openssh-server
正在读取软件包列表… 完成
正在分析软件包的依赖关系树… 完成
正在读取状态信息… 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
apt : 依赖: gpgv 或
gpgv2 但是它将不会被安装 或
gpgv1 但是它将不会被安装
依赖: libapt-pkg6.0 (>= 2.4.5) 但是它将不会被安装
bash : 预依赖: libtinfo6 (>= 6) 但无法安装它
dpkg : 预依赖: zlib1g (>= 1:1.1.4) 但无法安装它
fdisk : 依赖: libncursesw6 (>= 6) 但是它将不会被安装
依赖: libreadline8 (>= 6.0) 但是它将不会被安装
依赖: libtinfo6 (>= 6) 但无法安装它
init : 预依赖: systemd-sysv
libbsd0:i386 : 依赖: libc6:i386 (>= 2.25) 但无法安装它
libcbor0.6:i386 : 依赖: libc6:i386 (>= 2.4) 但无法安装它
libedit2:i386 : 依赖: libc6:i386 (>= 2.28) 但无法安装它
libfido2-1:i386 : 依赖: libc6:i386 (>= 2.25) 但无法安装它
libssl1.1:i386 : 依赖: libc6:i386 (>= 2.28) 但无法安装它
libtinfo6:i386 : 依赖: libc6:i386 (>= 2.16) 但无法安装它
libudev1:i386 : 依赖: libc6:i386 (>= 2.30) 但无法安装它
ncurses-bin : 预依赖: libtinfo6 (>= 6.3) 但无法安装它
openssh-client:i386 : 依赖: libc6:i386 (>= 2.28) 但无法安装它
依赖: libgssapi-krb5-2:i386 (>= 1.17) 但无法安装它
依赖: libselinux1:i386 (>= 1.32) 但无法安装它
推荐: xauth:i386
openssh-server : 依赖: procps
依赖: zlib1g (>= 1:1.1.4) 但无法安装它
推荐: default-logind 或
logind 或
libpam-systemd 但是它将不会被安装
推荐: xauth
推荐: ssh-import-id 但是它将不会被安装
shim-signed : 依赖: grub-efi-amd64-signed 但是它将不会被安装 或
grub-efi-arm64-signed 但无法安装它
依赖: grub2-common (>= 2.04-1ubuntu24) 但是它将不会被安装
util-linux : 预依赖: libtinfo6 (>= 6) 但无法安装它
预依赖: libudev1 (>= 183) 但无法安装它
预依赖: zlib1g (>= 1:1.1.4) 但无法安装它
zlib1g:i386 : 依赖: libc6:i386 (>= 2.4) 但无法安装它
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

 

 

后来,发现先卸载, openssh-client   之后再次安装就成功了,

sudo apt-get remove openssh-client

LINUX真是太折腾了,每个软件这个套那个那个套整个,一个出问题,折腾好久才行。


click to changeSecurity Code